12z ECMWF-EPS Delays

Incident Report for Commodity Weather Group

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 14:29 EST

Monitoring

Data is flowing again from ECMWF. We are processing the data as it arrives and monitoring for any further issues.
Posted Mar 03, 2026 - 13:51 EST

Investigating

The 12z ECMWF-EPS is currently delayed at ECMWF. We will provide an update as more information becomes available.
Posted Mar 03, 2026 - 13:46 EST
This incident affected: External Data Providers (ECMWF).