12z ECMWF/ECMWF-EPS Delayed
Incident Report for Commodity Weather Group
Resolved
Dissemination of the 12z ECMWF and ECMWF-EPS has completed.
Posted Mar 17, 2023 - 16:32 EDT
Investigating
The 12z ECMWF Op and ECMWF-EPS are delayed due to an unknown issue at ECMWF. We will monitor the situation and provide an update when more information becomes available.
Posted Mar 17, 2023 - 15:00 EDT
This incident affected: External Data Providers (ECMWF).