12z ECMWF Delays

Incident Report for Commodity Weather Group

Resolved

All 12z files have been disseminated.
Posted Jan 28, 2026 - 13:46 EST

Identified

ECMWF has indicated that the 12z operational and ensemble models will be delayed due to an issue with their dissemination system.
Posted Jan 28, 2026 - 13:27 EST
This incident affected: External Data Providers (ECMWF).