Late ECMWF Data

Incident Report for Commodity Weather Group

Resolved

All 12z ECMWF data have been disseminated and processed.
Posted Jan 21, 2026 - 14:47 EST

Update

We are continuing to monitor for any further issues.
Posted Jan 21, 2026 - 13:14 EST

Monitoring

We've seen the first hours of the ECMWF start to queue.
Posted Jan 21, 2026 - 12:38 EST

Investigating

We currently see no 12z data queued or being disseminated from ECMWF. We will process data as soon as they provide it.
Posted Jan 21, 2026 - 12:29 EST
This incident affected: External Data Providers (ECMWF).