ECMWF Delays

Incident Report for Commodity Weather Group

Resolved

This incident has been resolved.
Posted May 14, 2026 - 15:35 EDT

Monitoring

Dissemination of the 12z model suite by ECMWF has begun. We will continue to monitor until completion.
Posted May 14, 2026 - 14:22 EDT

Identified

ECMWF is reporting that data will be delayed by at least 30 minutes.
Posted May 14, 2026 - 13:50 EDT
This incident affected: External Data Providers (ECMWF).