ECMWF Delays

Incident Report for Commodity Weather Group

Resolved

Dissemination has completed for the 12z ECMWF products.
Posted Apr 14, 2026 - 15:36 EDT

Monitoring

We're seeing data starting to flow from ECMWF.
Posted Apr 14, 2026 - 14:04 EDT

Investigating

No signs for 12z data at ECMWF for the ECMWF, ECMWF-EPS, AIFS, and AIFS-ENS.
Posted Apr 14, 2026 - 13:32 EDT
This incident affected: External Data Providers (ECMWF).