ECMWF 12z Delays

Incident Report for Commodity Weather Group

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 16:03 EDT

Monitoring

12z op data is now flowing; we are monitoring.
Posted Jun 01, 2026 - 14:03 EDT

Identified

ECMWF has posted that there will be a "slight delay" with the dissemination of 12z data. We will update as we receive more information.
Posted Jun 01, 2026 - 13:53 EDT
This incident affected: External Data Providers (ECMWF).